Official EGwhaven thread.

Moderator: ETTiNGRiNDER

User avatar
ETTiNGRiNDER
Posts: 25
Joined: Sun May 22, 2016 12:23 pm
Contact:

Official EGwhaven thread.

Postby ETTiNGRiNDER » Thu May 26, 2016 9:39 pm

EGwhaven is my project to bugfix the Witchaven source code for improved playability. Currently, it runs on DOS (DOSbox emulation also works) and only supports Witchaven II as I haven't been able to properly compile the sources of the original Witchaven, yet.

Many fixes have been done, including timing fixes, control improvements and miscellaneous bug fixes.

Homepage:
http://ettingrinder.youfailit.net/wh-egwhaven.html

If you want to report bugs or otherwise discuss the project, feel free to do so in this thread.
User avatar
rgstever
Site Admin
Posts: 12
Joined: Fri May 20, 2016 12:34 pm

Re: Official EGwhaven thread.

Postby rgstever » Thu May 26, 2016 11:45 pm

Would you like your own .com address hosted by me?
It's entirely free.
Host and site admin.
User avatar
ETTiNGRiNDER
Posts: 25
Joined: Sun May 22, 2016 12:23 pm
Contact:

Re: Official EGwhaven thread.

Postby ETTiNGRiNDER » Sat May 28, 2016 12:20 pm

rgstever wrote:Would you like your own .com address hosted by me?
It's entirely free.

Thanks! I think I'm pretty well set with the hosting I currently have, but I'll keep the offer in mind.
User avatar
Corvin
Posts: 94
Joined: Fri May 20, 2016 1:10 pm
Location: R.T.C.M.
Contact:

Re: Official EGwhaven thread.

Postby Corvin » Fri Sep 16, 2016 6:49 am

I still haven't had a chance to run the latest EGWH(v0.5) to find any problems,

However I was wondering if you(EG) ran into any recently, or if anyone else has?
adambiser
Posts: 13
Joined: Fri Sep 16, 2016 2:06 pm

Re: Official EGwhaven thread.

Postby adambiser » Fri Sep 16, 2016 2:39 pm

Hi ETTiNGRiNDER, thanks so much for EGwhaven.

I recently bought a used copy of Witchaven II and have it set up to run using DOSBox 0.74. One thing I've noticed is that the SMK files stutter when I have cycles=auto, but the game runs smoothly. If I set cycles down to around 30000, the intro SMK plays fine, but the game is extremely slow. I've tried WH2 2.0C, 2.0G (with and without the internal DOS4GW), and EGWHAVEN 0.4 and 0.5. All seem to do the same thing. However, when I use SMACKPLY 2.0c which is found in the VICTORY directory on the CD, the SMK files play fine with no choppiness or stuttering audio with cycles=auto.

EDIT: DISREGARD. I am able to compile the source using Watcom 11.0c. OpenWatcom doesn't work.

To investigate whether I could fix it, I am trying to compile the EGwhaven 0.5 source and have grabbed "open-watcom-c-dos-1.9.exe" and installed it on a DOSBox mount. When I run MAKE.BAT on a fresh copy of the 0.5 source I get this in ERRORS:

Code: Select all

sndmod.h(573): Error! E1129: Type does not agree with previous definition of 'hSOSSongHandles'
sndmod.h(573): Note! I2002: 'hSOSSongHandles' defined in: sndmod.h(475)

So I commented out line 573 and try again.

Code: Select all

//extern int  hSOSSongHandles[];

It gets much farther now, but aborts after the wlink call and ERRORS has this:

Code: Select all

Error! E2028: setpalookupaddress_ is an undefined reference
Error! E2028: sethlinesizes_ is an undefined reference
Error! E2028: setupvlineasm_ is an undefined reference
(a bunch more like this...)
file engine.obj(D:\engine.c): undefined symbol setpalookupaddress_
file engine.obj(D:\engine.c): undefined symbol sethlinesizes_
file engine.obj(D:\engine.c): undefined symbol setupvlineasm_
(a bunch more like this...)

Do you happen to know what I could be doing wrong? This is my first time trying to use OpenWatcom.
Or if you happen to know about this SMK stuttering and how to fix it, I would appreciate it.
Thanks again for all!
Last edited by adambiser on Fri Sep 16, 2016 5:19 pm, edited 1 time in total.
User avatar
Corvin
Posts: 94
Joined: Fri May 20, 2016 1:10 pm
Location: R.T.C.M.
Contact:

Re: Official EGwhaven thread.

Postby Corvin » Fri Sep 16, 2016 3:02 pm

Cut-Scenes: They seem to play alright without sound but with sound some of the cut-scenes in some of the BUILD Games, may stutter and be choppy. Optionally use DOSBox EMU's CTRL-F11 to decrease cycles. This has been noticed to work in most of the games, including Witchaven II. CTRL-F12 increases cycles to return to a playable game.

This information is from the rtcm doc: http://www.r-t-c-m.com/knowledge-base/d ... oxemu.html

If I recall, EG has more specific information on his web site about the cycles in dosbox and the SMK media in WH2.
There is only one SMK video If I recall in each game.
adambiser
Posts: 13
Joined: Fri Sep 16, 2016 2:06 pm

Re: Official EGwhaven thread.

Postby adambiser » Fri Sep 16, 2016 3:16 pm

Corvin wrote:Cut-Scenes: They seem to play alright without sound but with sound some of the cut-scenes in some of the BUILD Games, may stutter and be choppy. Optionally use DOSBox EMU's CTRL-F11 to decrease cycles. This has been noticed to work in most of the games, including Witchaven II. CTRL-F12 increases cycles to return to a playable game.

This information is from the rtcm doc: http://www.r-t-c-m.com/knowledge-base/d ... oxemu.html

If I recall, EG has more specific information on his web site about the cycles in dosbox and the SMK media in WH2.
There is only one SMK video If I recall in each game.

WH2 has 5 in-game SMKs, INTRO, ENDING1, 2, 3, and STAIRS.
When I set cycles to auto or max, no amount of decreasing seems to correct it, If I instead start at 30000, I can increase to 200000 to get pretty smooth gameplay. I haven't tried going from 200000 to 30000. I believe BLOOD had SMK files, too and they played well for me.

I'll dig around EG's web site and try using settings from the link you mention. Thanks.
User avatar
Corvin
Posts: 94
Joined: Fri May 20, 2016 1:10 pm
Location: R.T.C.M.
Contact:

Re: Official EGwhaven thread.

Postby Corvin » Fri Sep 16, 2016 4:36 pm

Are the 5 Videos in one SMK file?

I'm asking cause I don't have my WH2 CD here with me.



EDIT: Nevermind, I have the iso right here, and there are indeed 5 SMKs.
BTW the cycles in DosBox emu to run the videos smoothly will probably be lower than the cycles needed to play the game smoothly. So for whatever speed of your computer you have to find a good range to set and adjust.

Like you said its probably better to update or fix the video playback in the source code.
adambiser
Posts: 13
Joined: Fri Sep 16, 2016 2:06 pm

Re: Official EGwhaven thread.

Postby adambiser » Fri Sep 16, 2016 5:20 pm

OK, I tried using Watcom 11.0c and the source compiles now. It doesn't compile with OpenWatcom.
adambiser
Posts: 13
Joined: Fri Sep 16, 2016 2:06 pm

Re: Official EGwhaven thread.

Postby adambiser » Fri Sep 16, 2016 8:21 pm

OK, after toying around with this, it appears like fixing the SMK with audio playback stutter is actually simple.

In WHSMK.C, find line 254...257:

Code: Select all

     if ((s == 0 || s == 1 || s == 3 || s == 4) && SoundMode)
     {
          smk=SmackOpen(tempbuf,SMACKTRACK1,SMACKAUTOEXTRA);
     }

change to:

Code: Select all

     if ((s == 0 || s == 1 || s == 3 || s == 4) && SoundMode)
     {
          smk=SmackOpen(tempbuf,SMACKTRACK1|SMACKNOSKIP,SMACKAUTOEXTRA);
     }

The SMACKNOSKIP flag doesn't seem to be necessary in the other SmackOpen call.

Return to “Witchaven”

Who is online

Users browsing this forum: No registered users and 1 guest